Back
Resolved

The web is not accessible issues

Started 28 Aug at 12:34am GMT+8.

https://blog.namran.net https://books.namran.com
Created

The following web services have been affected by the recent hardware failure in our data center service provider.
It is now mitigated by moving it to another location.
Thank you for your kind understanding.

Posted 28 Aug at 12:34am GMT+8.